242e6630af
Python NSS module is not buildable by pip on Debian/bullseye and requires patches. The debian package for this module contains the required fixes, but contains 2 other problems: - it builds only the PY3-version of itself - it (incorrectly) doesn't install pip metadata, making it "invisible" by pip Solution: import python-nss from debian/bullseye + add patches that fix the above problems. TESTS ================ Build package in debian environment Story: 2009897 Task: 44691 Signed-off-by: Davlet Panech <davlet.panech@windriver.com> Change-Id: I65ab9b967e38340939bd99c389b72820ee17571b
26 lines
726 B
Diff
26 lines
726 B
Diff
From 364a0606c58f100bbec4447fb34e03fcba2821e3 Mon Sep 17 00:00:00 2001
|
|
From: Davlet Panech <davlet.panech@windriver.com>
|
|
Date: Tue, 29 Mar 2022 15:26:11 -0400
|
|
Subject: [PATCH 1/2] Don't delete module metadata in deb package
|
|
|
|
Pip requires module metadata to be present for installed modules,
|
|
otherwise it can't "see" it.
|
|
|
|
Signed-off-by: Davlet Panech <davlet.panech@windriver.com>
|
|
---
|
|
debian/rules | 1 -
|
|
1 file changed, 1 deletion(-)
|
|
|
|
diff --git a/debian/rules b/debian/rules
|
|
index 7955ffd..ef6314b 100755
|
|
--- a/debian/rules
|
|
+++ b/debian/rules
|
|
@@ -13,4 +13,3 @@ override_dh_auto_clean:
|
|
|
|
override_dh_auto_install:
|
|
dh_auto_install
|
|
- rm -rf debian/python*-nss/usr/lib/python*/dist-packages/python_nss-*.egg-info
|
|
--
|
|
2.30.2
|
|
|