e17b830387
Upgrade Openscap tool to release 1.3.6, using the debianized version 1.3.6+dsfg-6 for the packaging files available at https://salsa.debian.org/debian/openscap/-/blob/debian/1.3.6+dfsg-6/debian/changelog Didn't change any files or patches. Segmentation faults during Openscap usage seen in Starlingx were fixed in this release of Openscap, and are the reason of this upgrade. Test Plan: PASS: Build iso. PASS: Deploy AIO-SX. PASS: Check version (oscap --version). Result should be 1.3.6. PASS: Run openscap using one of default manifests. There should be no segmentation fault issues. Command i.e.: "oscap xccdf eval --profile \ xccdf_org.ssgproject.content_profile_anssi_np_nt28_high \ --report controller-0-report.html \ /usr/share/xml/scap/ssg/content/ssg-debian11-ds-1.2.xml". Closes-Bug: 2006782 Signed-off-by: Marcelo de Castro Loebens <Marcelo.DeCastroLoebens@windriver.com> Change-Id: I34ff193227ae51ec709b7d69b6a97abc074721f3
43 lines
1.2 KiB
Diff
43 lines
1.2 KiB
Diff
From: =?utf-8?b?IkjDpXZhcmQgRi4gQWFzZW4i?= <havard.f.aasen@pfft.no>
|
|
Date: Sat, 30 Jul 2022 07:57:36 +0200
|
|
Subject: run a minor testsuite
|
|
|
|
Forwarded: not-needed
|
|
---
|
|
tests/CMakeLists.txt | 16 ++++++++--------
|
|
1 file changed, 8 insertions(+), 8 deletions(-)
|
|
|
|
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
|
|
index ae8c4f2..fa78bd5 100644
|
|
--- a/tests/CMakeLists.txt
|
|
+++ b/tests/CMakeLists.txt
|
|
@@ -22,20 +22,20 @@ endfunction()
|
|
|
|
configure_file("test_common.sh.in" "test_common.sh" @ONLY)
|
|
|
|
-add_subdirectory("API")
|
|
+#add_subdirectory("API")
|
|
add_subdirectory("bindings")
|
|
-add_subdirectory("bz2")
|
|
+#add_subdirectory("bz2")
|
|
add_subdirectory("codestyle")
|
|
-add_subdirectory("curl")
|
|
+#add_subdirectory("curl")
|
|
add_subdirectory("CPE")
|
|
-add_subdirectory("DS")
|
|
+#add_subdirectory("DS")
|
|
add_subdirectory("mitre")
|
|
-add_subdirectory("nist")
|
|
+#add_subdirectory("nist")
|
|
add_subdirectory("oscap_string")
|
|
add_subdirectory("oval_details")
|
|
-add_subdirectory("probes")
|
|
-add_subdirectory("report")
|
|
-add_subdirectory("sce")
|
|
+#add_subdirectory("probes")
|
|
+#add_subdirectory("report")
|
|
+#add_subdirectory("sce")
|
|
add_subdirectory("schemas")
|
|
add_subdirectory("sources")
|
|
add_subdirectory("utils")
|