meta-starlingx/meta-stx-cloud/recipes-devtools/erlang/erlang_R16B03-1.bbappend
Babak Sarashki 63b6601bdd meta-stx: update LICENSE and copyright info
- Change License from Apache2 to MIT.
- Remove Copyright from individual recipes
- Move License to README.md
- Add meta-stx Copyright to README.md

Signed-off-by: Babak Sarashki <Babak.SarAshki@windriver.com>
2020-06-08 13:00:26 -07:00

26 lines
643 B
Plaintext

FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
# erlang < 20.0 is not compatibel with OpenSSL 1.1.x
inherit openssl10
SRC_URI += " \
file://fix-install-ownership.patch \
"
EXTRA_OECONF = '--with-ssl=${STAGING_DIR_TARGET}/usr --without-krb5 --without-zlib'
do_configure_prepend () {
export erl_xcomp_sysroot="${STAGING_DIR_HOST}/usr"
export erl_xcomp_isysroot="${STAGING_DIR_NATIVE}"
sed -i -e 's/opensslconf.h/opensslconf-64.h/' \
${STAGING_INCDIR}/openssl10/openssl/rc4.h \
${STAGING_INCDIR}/openssl10/openssl/rc2.h
}
do_install_append () {
# Fix the do_package_qa issue
chown -R root:root ${D}
}