c74ebee4bc
The 'ifup' command provided by 'busybox' and 'ifupdown' behave differently when an interface has been configured: - The one from busybox $ sudo ifup lo; echo $? RTNETLINK answers: File exists 1 - The one from ifupdown $ sudo ifup lo; echo $? ifup: interface lo already configured 0 The exit code 1 from the busybox one would cause the networking service failed, so add RDEPENDS on ifupdown to avoid using the one from busybox. Partial-Bug: 1901820 Change-Id: I6400a343bb2eebbf95a971a97f98a50ce588b6b2 Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
11 lines
202 B
Plaintext
11 lines
202 B
Plaintext
do_install_append() {
|
|
rm -f ${D}/etc/network/interfaces
|
|
touch ${D}/etc/network/interfaces
|
|
cat > ${D}/etc/network/interfaces << EOF
|
|
auto lo
|
|
iface lo inet loopback
|
|
EOF
|
|
}
|
|
|
|
RDEPENDS_${PN} += "ifupdown"
|