Jackie Huang b582a3383a systemd-conf: update for stx 5.0
* inherit stx-metadata to help install updated files
  from stx 'config-files' repo

* remove do_copy_config_files since it's not
  needed after using stx-metadata

Story: 2008952
Task: 42576

Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
Change-Id: I46c5e71e969eb21facec0b4d2b88eb62cda98444
2021-06-24 17:07:06 +08:00

18 lines
490 B
Plaintext

FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
inherit stx-metadata
STX_REPO = "config-files"
STX_SUBPATH = "systemd-config"
LICENSE_append = "& Apache-2.0"
LIC_FILES_CHKSUM += "\
file://${STX_METADATA_PATH}/files/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
"
do_install_append () {
install -d -m 0755 ${D}/${sysconfdir}/systemd
install -m644 ${STX_METADATA_PATH}/files/journald.conf ${D}/${sysconfdir}/systemd/journald.conf
chmod 644 ${D}/${sysconfdir}/systemd/journald.conf
}