Jackie Huang 0242b01e0b postgresql: update for stx 5.0
update the PGDATA with correct STX_REL for stx 5.0

Story: 2008952
Task: 42576

Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
Change-Id: Id5cceed6551e9af4c7cb17753b55c01b5357ad15
2021-07-23 15:29:35 +08:00

19 lines
576 B
Plaintext

COMPUTE_IP="127.0.0.1"
CONTROLLER_IP="127.0.0.1"
FILESEXTRAPATHS_prepend := "${THISDIR}/postgresql:"
require ${@bb.utils.contains('DISTRO_FEATURES', 'openstack', '${BPN}_openstack.inc', '', d)}
SRC_URI += " \
file://postgresql.service.update \
"
do_install_append() {
install -d ${D}${systemd_unitdir}/system
install -m 0755 ${WORKDIR}/postgresql.service.update ${D}${systemd_unitdir}/system/postgresql.service
sed -i -e "s/@STX_REL@/${STX_REL}/" ${D}${systemd_unitdir}/system/postgresql.service
}
FILES_${PN} += "${systemd_unitdir}/system/postgresql.service"