b69e9b2873
* The newer version is required by kubernetes 1.18.1 * The recipes are copied from dunfell branch in oe-core, which will be removed in the future if we move to yocto 3.0 (dunfell) or newer version. Story: 2008952 Task: 42576 Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Change-Id: I1a223d3466286cf8a4a640290eee07b265d88fed
15 lines
553 B
BlitzBasic
15 lines
553 B
BlitzBasic
require go-${PV}.inc
|
|
require go-target.inc
|
|
|
|
export GOBUILDMODE=""
|
|
export CGO_ENABLED_riscv64 = ""
|
|
# Add pie to GOBUILDMODE to satisfy "textrel" QA checking, but
|
|
# windows/mips/riscv doesn't support -buildmode=pie, so skip the QA checking
|
|
# for windows/mips/riscv and their variants.
|
|
python() {
|
|
if 'mips' in d.getVar('TARGET_ARCH',True) or 'riscv' in d.getVar('TARGET_ARCH',True) or 'windows' in d.getVar('TARGET_GOOS', True):
|
|
d.appendVar('INSANE_SKIP_%s' % d.getVar('PN',True), " textrel")
|
|
else:
|
|
d.setVar('GOBUILDMODE', 'pie')
|
|
}
|