meta-starlingx/meta-stx-integ/recipes-networking/ipset/ipset_6.38.bb
Babak Sarashki 63b6601bdd meta-stx: update LICENSE and copyright info
- Change License from Apache2 to MIT.
- Remove Copyright from individual recipes
- Move License to README.md
- Add meta-stx Copyright to README.md

Signed-off-by: Babak Sarashki <Babak.SarAshki@windriver.com>
2020-06-08 13:00:26 -07:00

57 lines
2.0 KiB
BlitzBasic

SUMMARY = "Manage Linux IP sets"
DESCRIPTION = " \
IP sets are a framework inside the Linux kernel since version 2.4.x, which can \
be administered by the ipset utility. Depending on the type, currently an IP \
set may store IP addresses, (TCP/UDP) port numbers or IP addresses with MAC \
addresses in a way, which ensures lightning speed when matching an entry \
against a set. \
\
If you want to: \
- store multiple IP addresses or port numbers and match against the collection \
by iptables at one swoop; \
- dynamically update iptables rules against IP addresses or ports without \
performance penalty; \
- express complex IP address and ports based rulesets with one single iptables \
rule and benefit from the speed of IP sets \
then ipset may be the proper tool for you. \
"
HOMEPAGE = "http://ipset.netfilter.org"
LICENSE = "GPL-2.0"
LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
SECTION = "network"
DEPENDS = "libtool libmnl"
SRC_URI = "http://ftp.netfilter.org/pub/ipset/${BP}.tar.bz2"
SRC_URI[md5sum] = "0e5d9c85f6b78e7dff0c996e2900574b"
SRC_URI[sha256sum] = "ceef625ba31fe0aaa422926c7231a819de0b07644c02c17ebdd3022a29e3e244"
inherit autotools pkgconfig module-base
EXTRA_OECONF += "-with-kbuild=${KBUILD_OUTPUT} --with-ksource=${STAGING_KERNEL_DIR}"
RDEPENDS_${PN} = "kernel-module-ip-set"
RRECOMMENDS_${PN} = "\
kernel-module-ip-set-bitmap-ip \
kernel-module-ip-set-bitmap-ipmac \
kernel-module-ip-set-bitmap-port \
kernel-module-ip-set-hash-ip \
kernel-module-ip-set-hash-ipmac \
kernel-module-ip-set-hash-ipmark \
kernel-module-ip-set-hash-ipport \
kernel-module-ip-set-hash-ipportip \
kernel-module-ip-set-hash-ipportnet \
kernel-module-ip-set-hash-mac \
kernel-module-ip-set-hash-net \
kernel-module-ip-set-hash-netiface \
kernel-module-ip-set-hash-netnet \
kernel-module-ip-set-hash-netport \
kernel-module-ip-set-hash-netportnet \
kernel-module-ip-set-list-set \
"